Status

Invalid certificate errors Friday 2nd April 2021 14:33:00


We are currently experiencing a service disruption impacting the Menlo Security Web Isolation.

Users in the California, Virginia, Ireland, Frankfurt, Paris and Mumbai may be experiencing invalid certificate errors when browsing through Menlo Security.

The Menlo Security Operations team has identified an incorrect certificate chain and is pushing out a change to update the certificate.

We will send an additional update in 20 minutes.

Update 22:05 UTC The update to cycle out hosts with the incorrect certificate chain is ongoing and expected to finish within the next 30 minutes.

Update 22:28 UTC Host cycling is complete and verification is complete.